Connectivity issues with some AWS instances
Incident Report for ElephantSQL
Resolved
This incident is now resolved and we've re-enabled auto-failover for follower plans.
Posted May 27, 2022 - 09:17 UTC
Monitoring
Amazon Route 53 DNS is now fully operational again.

10:24 PM PDT "Between 5:35 PM and 9:58 PM PDT, we experienced intermittent DNS resolution issues for certain specific AWS endpoints. We can confirm that DNS resolution issues for these AWS names have been resolved. Since DNS answers for some of these names that were affected by issues with the third-party DNS provider could have been cached on AWS DNS resolvers, we are flushing these resolver caches over the next few hours. If you run your own DNS Resolvers, and you experience DNS resolution issues we suggest to flush your DNS Resolver cache." - https://health.aws.amazon.com/
Posted May 27, 2022 - 06:59 UTC
Update
Update from AWS:

"​We are aware of intermediate DNS resolution issues for certain specific AWS names. This is due to an issue with third-party DNS provider outside AWS.
DNS queries for domains hosted on Route 53 are operating without any issues at this time.
We are actively working with the third-party DNS provider to resolve the issue as quickly as possible."
Posted May 27, 2022 - 02:45 UTC
Investigating
We have disabled auto-failover for follower plans due to the issue.
Posted May 27, 2022 - 01:33 UTC
This incident affected: AWS ec2-ap-northeast-1, AWS ec2-ap-northeast-2, AWS ec2-ap-southeast-1, AWS ec2-ca-central-1, AWS ec2-ap-southeast-2, AWS ec2-eu-central-1, AWS ec2-eu-west-1, AWS ec2-eu-west-3, AWS ec2-eu-west-2, AWS ec2-sa-east-1, AWS ec2-us-east-1, AWS ec2-us-east-2, AWS ec2-us-west-1, AWS ec2-us-west-2, AWS ec2-af-south-1, AWS ec2-ap-east-1, AWS ec2-ap-south-1, AWS ec2-eu-north-1, and AWS ec2-me-south-1.